mercedes forums   mercedes forums

Go Back   Mercedes Forum > Mercedes-Benz Forums (Mercedes SUVs) > Mercedes M-Class Forum

Mercedes Forum: Problems with parents' Mercedes ML350?
Reply
 
Thread Tools Display Modes
  #1  
Old 11-28-2008, 12:06 PM
Peter L Peter L is offline
Junior Member
 
Join Date: Nov 2008
Posts: 2
Default Problems with parents' Mercedes ML350?

Hi, one day while riding in our 2007 ML350, it wouldn't shift! And the reverse made a really weird noise when engaged. That noise continued when backing up too. My mom had her foot to the floor and it would only go 20 mph. It said ESP wasn't working and there were a few other malfunctions. What price are we looking at for fixing this problem and what is it?
Reply With Quote

lose weight
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:49 AM.


Advertisements
cars connected social network


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
mercedesforums.net recognizes that "Mercedes", it's logos and various model names and numbers are registered trademarks of Daimler AG. These terms are used for identification purposes only. mercedesforums.net is not affiliated in any way with Daimler AG. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on MercedesForums.net requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Mercedes? Check out your options at the links below: